import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[+-]?\\d+(?:\\.\\d+)?(?:\\s+[+-]?\\d+(?:\\.\\d+)?){0,2}";
final String string = "5.2 -34 435, 34 2.908 3, 50 2 54 3, 40 50";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}