re = /[+-]?\d+(?:\.\d+)?(?:\s+[+-]?\d+(?:\.\d+)?){0,2}/m
str = '5.2 -34 435, 34 2.908 3, 50 2 54 3, 40 50'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end