$re = '~[+-]?\d+(?:\.\d+)?(?:\s+[+-]?\d+(?:\.\d+)?){0,2}~m';
$str = '5.2 -34 435, 34 2.908 3, 50 2 54 3, 40 50';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);