#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Judge(?: +[A-Z][^\W\d_]*\.?)*"
Local $sString = "® @ Stperio,l LED" & @CRLF & _
">" & @CRLF & _
"Cay" & @CRLF & _
"OCT 9, "se"" & @CRLF & _
"-aeentative Ruling Sherr p 8 29" & @CRLF & _
"by C. 17" & @CRLF & _
"% Exeo, ive On Z—" & @CRLF & _
"Judge Randolph M. Hammock, Department 47 Fie oH/erp" & @CRLF & _
"a, Copy," & @CRLF & _
"HEARING DATE: October 18, 2017 TRIAL DATE: March 27, 20 18" & @CRLF & _
". CASE: Roger Lee Harrison v. Taylor Hackford, et al. ©" & @CRLF & _
"CASE NO.: BC596850"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")