import re
regex = re.compile(r"Judge(?: +[A-Z][^\W\d_]*\.?)*", flags=re.MULTILINE)
test_str = ("® @ Stperio,l LED\n"
">\n"
"Cay\n"
"OCT 9, \"se\"\n"
"-aeentative Ruling Sherr p 8 29\n"
"by C. 17\n"
"% Exeo, ive On Z—\n"
"Judge Randolph M. Hammock, Department 47 Fie oH/erp\n"
"a, Copy,\n"
"HEARING DATE: October 18, 2017 TRIAL DATE: March 27, 20 18\n"
". CASE: Roger Lee Harrison v. Taylor Hackford, et al. ©\n"
"CASE NO.: BC596850")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")