$re = '/Judge(?: +[A-Z][^\W\d_]*\.?)*/m';
$str = '® @ Stperio,l LED
>
Cay
OCT 9, "se"
-aeentative Ruling Sherr p 8 29
by C. 17
% Exeo, ive On Z—
Judge Randolph M. Hammock, Department 47 Fie oH/erp
a, Copy,
HEARING DATE: October 18, 2017 TRIAL DATE: March 27, 20 18
. CASE: Roger Lee Harrison v. Taylor Hackford, et al. ©
CASE NO.: BC596850';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);