#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*/([^.]+)\.py::([^[\n]+(\[[^]]*]|))$"
Local $sString = "CERTIFICATION/repos_1/test_examples_1_01_C.py::test_case[6]" & @CRLF & _
"CERTIFICATION/repos_1/test_examples_2_01_C.py::test_case[7]" & @CRLF & _
"INTEGRATION/test_example_scan_1.py::test_case" & @CRLF & _
"INTEGRATION/test_example_scan_2.py::test_case"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")