# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*/([^.]+)\.py::([^[\n]+(\[[^]]*]|))$"
test_str = ("CERTIFICATION/repos_1/test_examples_1_01_C.py::test_case[6]\n"
"CERTIFICATION/repos_1/test_examples_2_01_C.py::test_case[7]\n"
"INTEGRATION/test_example_scan_1.py::test_case\n"
"INTEGRATION/test_example_scan_2.py::test_case")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.