re = /^.*\/([^.]+)\.py::([^[\n]+(\[[^]]*]|))$/m
str = 'CERTIFICATION/repos_1/test_examples_1_01_C.py::test_case[6]
CERTIFICATION/repos_1/test_examples_2_01_C.py::test_case[7]
INTEGRATION/test_example_scan_1.py::test_case
INTEGRATION/test_example_scan_2.py::test_case'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end