import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\n"
+ " ((?:22[0-3]|2([0-1])?\\d?|([1-9][0-9]?|1[0-9]{2}))\\.) # a group, 1-223 with \".\"\n"
+ " ((?:25[0-5]|2[0-4]\\d|[01]?(\\d{0,2}))\\.){2} # b and c groups 0-255 with \".\"\n"
+ "((25[0-5]|2[0-4]\\d|[01]?(\\d{0,2})) # d group, ends with optional netmask instead of \".\" // i tried making this non-optional as a group to solve my problem.\n"
+ "(\\/([89]|[12]\\d|3[0-2]))?) # netmask\n"
+ ",?\\h?){1,50}$ # allow comma separated, optional space between, up to 50 IPs";
final String string = "1.1.1.\n"
+ "1.1.1.2\n"
+ "1.1.1.2/23\n"
+ "1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}