use strict;
my $str = '1.1.1.
1.1.1.2
1.1.1.2/23
1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23';
my $regex = qr/^(
((?:22[0-3]|2([0-1])?\d?|([1-9][0-9]?|1[0-9]{2}))\.) # a group, 1-223 with "."
((?:25[0-5]|2[0-4]\d|[01]?(\d{0,2}))\.){2} # b and c groups 0-255 with "."
((25[0-5]|2[0-4]\d|[01]?(\d{0,2})) # d group, ends with optional netmask instead of "." // i tried making this non-optional as a group to solve my problem.
(\/([89]|[12]\d|3[0-2]))?) # netmask
,?\h?){1,50}$ # allow comma separated, optional space between, up to 50 IPs/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}