using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+) ?KG";
string input = @"Material xyz, with q in 25KG and with a bow tie.
Material xyz, with q in ,25KG and with a bow tie.
Material xyz, with q in 25KG, and with a bow tie.
Material xyz, with q in 25 KG and with a bow tie.
Material xyz, with q in ,25 KG and with a bow tie.
Material xyz, with q in 25 KG, and with a bow tie.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}