re = /(\d+) ?KG/m
str = 'Material xyz, with q in 25KG and with a bow tie.
Material xyz, with q in ,25KG and with a bow tie.
Material xyz, with q in 25KG, and with a bow tie.
Material xyz, with q in 25 KG and with a bow tie.
Material xyz, with q in ,25 KG and with a bow tie.
Material xyz, with q in 25 KG, and with a bow tie.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end