// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+) ?KG").unwrap();
let string = "Material xyz, with q in 25KG and with a bow tie.
Material xyz, with q in ,25KG and with a bow tie.
Material xyz, with q in 25KG, and with a bow tie.
Material xyz, with q in 25 KG and with a bow tie.
Material xyz, with q in ,25 KG and with a bow tie.
Material xyz, with q in 25 KG, and with a bow tie.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}