package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|[^_])__([^\s_]([^_]+?)?[^\s_])__([^_]|$)`)
var str = `-- funciona
__foo bar__
__f o o b a r__
**teste __lorem ipsum__ dolor sit**
__teste **lorem ipsum** dolor sit__
abc__xyz__teste
-- não funciona (mas deveria)
__foo_bar__
__a__
__*__
__foo_*bar__
-- não é para funcionar
__ foo bar__
__foo bar __
__ foo __
_foo_
__foo_
_foo__
__ __
__a____
____a__
_____
-- corner case: aninhado (não tratei pois não sei o que deveria fazer)
__abc__xyz__123__
__abc __xyz__ 123__
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}