# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^|[^_])__([^\s_]([^_]+?)?[^\s_])__([^_]|$)"
test_str = ("-- funciona\n"
"__foo bar__\n"
"__f o o b a r__\n"
"**teste __lorem ipsum__ dolor sit**\n"
"__teste **lorem ipsum** dolor sit__\n"
"abc__xyz__teste\n\n"
"-- não funciona (mas deveria)\n"
"__foo_bar__\n"
"__a__\n"
"__*__\n"
"__foo_*bar__\n\n"
"-- não é para funcionar\n"
"__ foo bar__\n"
"__foo bar __\n"
"__ foo __\n"
"_foo_\n"
"__foo_\n"
"_foo__\n"
"__ __\n"
"__a____\n"
"____a__\n"
"_____\n\n"
"-- corner case: aninhado (não tratei pois não sei o que deveria fazer)\n"
"__abc__xyz__123__\n"
"__abc __xyz__ 123__\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.