import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|[^_])__([^\\s_]([^_]+?)?[^\\s_])__([^_]|$)";
final String string = "-- funciona\n"
+ "__foo bar__\n"
+ "__f o o b a r__\n"
+ "**teste __lorem ipsum__ dolor sit**\n"
+ "__teste **lorem ipsum** dolor sit__\n"
+ "abc__xyz__teste\n\n"
+ "-- não funciona (mas deveria)\n"
+ "__foo_bar__\n"
+ "__a__\n"
+ "__*__\n"
+ "__foo_*bar__\n\n"
+ "-- não é para funcionar\n"
+ "__ foo bar__\n"
+ "__foo bar __\n"
+ "__ foo __\n"
+ "_foo_\n"
+ "__foo_\n"
+ "_foo__\n"
+ "__ __\n"
+ "__a____\n"
+ "____a__\n"
+ "_____\n\n"
+ "-- corner case: aninhado (não tratei pois não sei o que deveria fazer)\n"
+ "__abc__xyz__123__\n"
+ "__abc __xyz__ 123__\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}