const regex = /^(?!(?:\d*\.){2})[.\d]{1,18}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:\\d*\\.){2})[.\\d]{1,18}$', 'gm')
const str = `12345.23
123456789012345678
12345.22.45
1234567890123456712`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}