$re = '/^(?!(?:\d*\.){2})[.\d]{1,18}$/m';
$str = '12345.23
123456789012345678
12345.22.45
1234567890123456712';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);