re = /^(?!(?:\d*\.){2})[.\d]{1,18}$/m
str = '12345.23
123456789012345678
12345.22.45
1234567890123456712'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end