#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+(?:\[\d+\]\w+)?)(?=\[\d+\])|(?<=\[)\d+(?=\])"
Local $sString = "testnames[3]" & @CRLF & _
"3alpha[0]" & @CRLF & _
"beta[4]value[2]" & @CRLF & _
"gama4[23]" & @CRLF & _
"tama[2334]" & @CRLF & _
"tes[t[" & @CRLF & _
"try[]t"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")