$re = '/(\w+(?:\[\d+\]\w+)?)(?=\[\d+\])|(?<=\[)\d+(?=\])/m';
$str = 'testnames[3]
3alpha[0]
beta[4]value[2]
gama4[23]
tama[2334]
tes[t[
try[]t';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);