using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+(?:\[\d+\]\w+)?)(?=\[\d+\])|(?<=\[)\d+(?=\])";
string input = @"testnames[3]
3alpha[0]
beta[4]value[2]
gama4[23]
tama[2334]
tes[t[
try[]t";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}