$re = '/^(?=(?:[^a-zA-Z\n]*[a-zA-Z]){2}).{8,}$/m';
$str = 'helloworl
HelloWorld-1
Y1232456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);