#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z0-9]*(?:_(?!_)[A-Za-z0-9]*)*$"
Local $sString = "_" & @CRLF & _
"AAA_A" & @CRLF & _
" - True" & @CRLF & _
"A_AA_A" & @CRLF & _
" - True" & @CRLF & _
"A__AA" & @CRLF & _
" - False"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")