re = /^[A-Za-z0-9]*(?:_(?!_)[A-Za-z0-9]*)*$/m
str = '_
AAA_A
- True
A_AA_A
- True
A__AA
- False'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end