$re = '/^[A-Za-z0-9]*(?:_(?!_)[A-Za-z0-9]*)*$/m';
$str = '_
AAA_A
- True
A_AA_A
- True
A__AA
- False';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);