import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=</)\\x20+(?=\\w+>)";
final String string = "This is title\n"
+ "<p>There is unwanted space< /p>\n"
+ "<h1>There is unwanted space< /h1>\n"
+ "<div>There is unwanted space< /div >\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}