re = /(?<=<\/)\x20+(?=\w+>)/m
str = 'This is title
<p>There is unwanted space< /p>
<h1>There is unwanted space< /h1>
<div>There is unwanted space< /div >
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end