$re = '/(?<=</)\x20+(?=\w+>)/m';
$str = 'This is title
<p>There is unwanted space< /p>
<h1>There is unwanted space< /h1>
<div>There is unwanted space< /div >
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);