using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]|[a-z, A-Z]";
string input = @"trhrththrthrthrth{grgrgehtht}hrthrth765fdlkgnjjknhijn6546t346 f34543545454540%%{{{}}}]]][[{{{[[[]] \t ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}