$re = '/[0-9]|[a-z, A-Z]/m';
$str = 'trhrththrthrthrth{grgrgehtht}hrthrth765fdlkgnjjknhijn6546t346 f34543545454540%%{{{}}}]]][[{{{[[[]] \\t ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);