re = /[0-9]|[a-z, A-Z]/m
str = 'trhrththrthrthrth{grgrgehtht}hrthrth765fdlkgnjjknhijn6546t346 f34543545454540%%{{{}}}]]][[{{{[[[]] \\t '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end