package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\B(room)\B|\b(room)\b|(room)`)
var str = `Meeting.Room
MeetingRoom21
Room
Meeting2Room
Meeting.room
12MeetingRoom110.MeetingRoom`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}