import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\B(room)\\B|\\b(room)\\b|(room)";
final String string = "Meeting.Room\n"
+ "MeetingRoom21\n"
+ "Room\n"
+ "Meeting2Room\n"
+ "Meeting.room\n"
+ "12MeetingRoom110.MeetingRoom";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}