$re = '/{([1-6],|[8-9],|10,){8}([1-6]|[8-9]|10)}/m';
$str = '{1,2,4,3,5,6,9,8,10}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);