// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m){([1-6],|[8-9],|10,){8}([1-6]|[8-9]|10)}").unwrap();
let string = "{1,2,4,3,5,6,9,8,10}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}