import re
regex = re.compile(r"{([1-6],|[8-9],|10,){8}([1-6]|[8-9]|10)}", flags=re.MULTILINE)
test_str = "{1,2,4,3,5,6,9,8,10}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")