using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(fit-or-vertical|wrap|wrap-or-vertical)(?!-)\b";
string input = @"wrap-or-vertical
wrap-or-vertical
wrap-or-verticalxxx
abc-wrap";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}