import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(fit-or-vertical|wrap|wrap-or-vertical)(?!-)\\b";
final String string = "wrap-or-vertical\n"
+ " wrap-or-vertical \n"
+ "wrap-or-verticalxxx\n"
+ "abc-wrap";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}