$re = '/\b(fit-or-vertical|wrap|wrap-or-vertical)(?!-)\b/m';
$str = 'wrap-or-vertical
wrap-or-vertical
wrap-or-verticalxxx
abc-wrap';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);