import re
regex = re.compile(r"(M.{2,}?)<STOP>", flags=re.MULTILINE)
test_str = ("res = [\n"
" 'NVAKMFPQRKFT<STOP>TVQTLMRNGTLLERG<STOP>CCEVSP',\n\n"
" 'QKRMDCNASV<STOP>TVTVQTLMQTL<STOP>TNTPKGG<STOP>',\n\n"
" 'MEKGYADAE<STOP>RKTF<STOP>MTVRAGCCGI<STOP>MK'\n"
"]\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")