re = /(M.{2,}?)<STOP>/m
str = 'res = [
\'NVAKMFPQRKFT<STOP>TVQTLMRNGTLLERG<STOP>CCEVSP\',
\'QKRMDCNASV<STOP>TVTVQTLMQTL<STOP>TNTPKGG<STOP>\',
\'MEKGYADAE<STOP>RKTF<STOP>MTVRAGCCGI<STOP>MK\'
]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end