package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^{]*)({[^}]*})*`)
var str = `Hello{MouseClick('left',100,100)} world{MouseClick('left',200,200)}.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}