$re = '/([^{]*)({[^}]*})*/m';
$str = 'Hello{MouseClick(\'left\',100,100)} world{MouseClick(\'left\',200,200)}.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);