re = /([^{]*)({[^}]*})*/m
str = 'Hello{MouseClick(\'left\',100,100)} world{MouseClick(\'left\',200,200)}.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end