$re = '/\{\{someText\(?(\d+)?\|?([^\n\r|]+)?\)?\}\}/m';
$str = '{{someText(20|Hello World)}}
{{someText(20|abcdèfg)}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);