re = /\{\{someText\(?(\d+)?\|?([^\n\r|]+)?\)?\}\}/m
str = '{{someText(20|Hello World)}}
{{someText(20|abcdèfg)}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end