// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\{\{someText\(?(\d+)?\|?([^\n\r|]+)?\)?\}\}").unwrap();
let string = "{{someText(20|Hello World)}}
{{someText(20|abcdèfg)}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}