use strict;
my $str = 'Morbi leo risus, \\x1b[34;1mporta ac consectetur\\x1b[39;22m ac, vestibulum at eros. Aenean lacinia bibendum nulla sed consectetur. Nullam id dolor id nibh ultricies vehicula ut id elit. Aenean lacinia bibendum nulla sed consectetur. Curabitur blandit tempus porttitor.';
my $regex = qr~(?=(?:(?:\\x1b\[[0-9;]+m)?.){80})(?:(?:\\x1b\[[0-9;]+m)?.){0,80}\K ~up;
my $subst = '\\n';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";